Issue
When attempting to activate Entra Backup, you receive the following error message: 'Authorization failed. Please review your Sign-in Logs in Microsoft Entra ID to troubleshoot and try again once resolved.'
Environment
- NinjaOne SaaS Backup
- Microsoft Entra ID
Cause
You may have an incorrectly configured conditional access policy in the target Microsoft Entra ID tenant.
Resolution
To resolve this error, log in to the Microsoft Entra portal from a company-managed or compliant device and check the sign-in logs as follows:
- Navigate to https://entra.microsoft.com and log in using an administrator account.
- Navigate to Manage → Security.
- Navigate to Protect → Conditional Access.
- Navigate to Monitoring → Sign-in logs. This page shows the status and its corresponding sign-in error code, which may vary depending on the issue.
- Navigate to Conditional Access → Sign-in logs.
- Click Add filters and then select Application.
- click Apply.
- Input the application name: NinjaOne [RegionCode] SaaS Backup (Entra ID - Backup Only) for native Ninja user, or Entra Backup - Backup Only for other regions.
- Review the displayed log list for log entries that indicate a Failure of Interrupted status. Click the suspected log entry to see more details.
Review the Detail log to check the failure reason and see if it's related to conditional access. If the log mentions conditional access in the error details, check the Conditional Access / Report-only tab.
If the issue persists, you can exclude our apps by following these steps:
- Navigate to Conditional Access → Policies.
- Select the policy you wish to exclude from the list.
- Navigate to Target resources.
- Click Exclude, then check Users and groups.
- A dialog will appear. Check users, then click Select.
Additional Resources
For more information about Entra Backup, refer to: Setting Up Entra Backup.
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