Error: Google Groups App is Blocked

Doug Chanin
Doug Chanin
  • Updated

Issue

When attempting to access Google Groups from NinjaOne SaaS Backup, you receive the error message "This app is blocked".

App is Blocked Error.jpg
Figure 1: Error message (click to enlarge)

Environment

NinjaOne SaaS Backup

Cause

NinjaOne SaaS Backup does not have permission to access restricted data.

Resolution

To resolve this issue, you'll need to grant NinjaOne SaaS Backup access to the restricted data in Google Vaults and Google Groups. 

Ensure the App IDs are Set to Trusted

You must set the NinjaOne SaaS Backup app to Trusted in order to access Google Vaults and Google Groups. To do so, perform each of the following steps:

  1. Log in as an administrator to the Google administrator Portal.
  2. Navigate to API Controls → Manage Third-Party App Access → Add App → OAuth App Name or Client ID
  3. Search for both of the two app IDs listed below:
    • 651888057438-e3180fh1ik4ncmf9arq1m84pe9qarnm8.apps.googleusercontent.com
    • 644855987626-fjin7vh14lkjnojp99plfqgogcu2olbh.apps.googleusercontent.com
  4. Select each of the above apps from the list, then click Access to Google Data.
  5. Click the Trusted radio button.
  6. Click SAVE.
If the app IDs listed above are not in the app list, then you have not configured them correctly, and Google will not allow access. You will need to contact NinjaOne SaaS Backup Support for additional assistance.

Check for a Manual Block

It's also possible that an administrator may have manually moved the app to the Blocked list. You can check for and resolve this issue with the following steps:

  1. In the Google administrator portal, navigate to Third-Party App Access and filter by Blocked.
  2. Ensure the Client ID for NinjaOne SaaS Backup is not on the Blocked list.

 

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